Documentation PHP

Installation

En utilisant l'option de compilation --enable-dba=shared, vous pouvez compiler un module dynamique qui activera le support des bases de données de style DBM pour PHP. Vous devez aussi ajouter le support d'au moins l'un des gestionnaires suivants, en spécifiant l'option de configuration --with-XXXX lors de la configuration de PHP.

Avertissement

Après avoir configuré et compilé PHP, vous devez exécuter les test suivants à partir de la ligne de commande : php run-tests.php ext/dba. Cela montre si votre combinaison de descripteurs fonctionne. Les plus problématiques sont dbm et ndbm qui entrent en conflit avec nombre d'installations. Ceci est dû au fait que sur de nombreux systèmes, ces bibliothèques font parties de plus d'une bibliothèque. Le test de configuration vous empêche juste de configurer des descripteurs dont la combinaison est défectueuse alors qu'ils fonctionnent correctement séparément.

Gestionnaires DBA supportés
Gestionnaire Option de configuration
dbm Pour activer le support de dbm, ajoutez --with-dbm[=DIR].

Note: dbm est une surcouche qui aboutit souvent à des échecs. Ainsi, vous ne devez utiliser dbm que si vous êtes sûrs qu'il fonctionne et que vous avez besoin de ce format.

ndbm Pour activer le support de ndbm, ajoutez --with-ndbm[=DIR].

Note: ndbm est une surcouche qui aboutit souvent à des échecs. Ainsi, vous ne devez utiliser ndbm que si vous êtes sûrs qu'il fonctionne et que vous avez besoin de ce format.

gdbm Pour activer le support de gdbm, ajoutez --with-gdbm[=DIR].
db2 Pour activer le support de db2, ajoutez --with-db2[=DIR].

Note: db2 entre en conflit avec db3 et db4.

db3 Pour activer le support de db3, ajoutez --with-db3[=DIR].

Note: db3 entre en conflit avec db2 et db4.

db4 Pour activer le support de db4, ajoutez --with-db4[=DIR].

Note: db4 entre en conflit avec db2 et db3.

Note: Ceci a été introduit avec PHP 4.3.2. Dans des versions précédentes de PHP, vous devez utiliser --with-db3=DIR où DIR pointe vers le répertoire ou se situe la bibliothèque db4. Il n'est pas possible d'utiliser des versions de db supérieures à 4.1 avec des versions de PHP antérieures à 4.3.0. De même, les bibliothèques db avec des versions allant de 4.1 à 4.1.24 ne peuvent être utilisées avec aucune version de PHP.

cdb Pour activer le support de cdb, ajoutez --with-cdb[=DIR].

Note: Depuis PHP 4.3.0, vous pouvez omettre d'utiliser DIR, afin d'exploiter la bibliothèque cdb fournie avec PHP, qui ajoute un gestionnaire cdb_make, permet la création de fichier cdb et permet l'accès aux fichiers cbd via le réseau avec les flux de PHP.

flatfile Pour activer le support des fichiers, ajoutez --with-flatfile.

Note: Ceci a été ajouté à PHP 4.3.0 pour assurer la compatibilité avec l'extension dbm qui est obsolète. Utilisez ce gestionnaire seulement quand vous ne pouvez installer aucun autre gestionnaire et que vous ne pouvez pas utiliser le gestionnaire cdb intégré.

inifile Pour activer le support de inifile, ajoutez l'option de compilation --with-inifile.

Note: Cette option a été ajoutée avec PHP 5.0.0 et permet de lire et écrire dans des fichiers d'initialisation de type Microsoft (.ini), comme le php.ini par exemple.

qdbm Pour activer le support de qdbm, ajoutez l'option de compilation --with-qdbm[=DIR].

Note: qdbm entre en conflit avec dbm et gdbm.

Note: Cette option a été ajoutée avec PHP 5.0.0. La bibliothèque qdbm peut être téléchargée sur » http://qdbm.sourceforge.net.

Note: Jusqu'en PHP 4.3.0, il était possible d'utiliser simultanément les gestionnaires db2 et db3 mais juste avec un seul en interne. Cela signifie que vous ne pouvez pas avoir les deux formats de fichiers. Depuis PHP 5.0.0, une vérification est faite lors de la configuration pour éviter ces problèmes.



Ceci n'est pas la documentation originale du langage de programmation php, pour y accéder visiter le site www.php.net

Support du web, outils, services, compteurs, scripts, générateurs et autres outils pour les webmasters gratuitement à 100%
Page générée en 0.001554 secondes.